[dev] Re: wmii; make with /bin/bash not with /bin/sh

From: David Engster <deng_AT_randomsample.de>
Date: Mon, 31 May 2010 20:17:24 +0200

David Schmid writes:
> David Engster wrote:
>> Robert Ransom writes:
>>> On Thu, 20 May 2010 14:51:37 +0200
>>> David Schmid <info_AT_david-schmid.de> wrote:
>>>> Measures tried:
>>>> - resetting PATH, since make calls /bin/sh and not sh it is
>>>> never looked up there
>>>> - setting BINSH or SHELL to /bin/bash won't work either.
>>>> - Asking for help at #suckless did not come up with immediate solution.
>>> I just tried "SHELL=/bin/echo make foo.o" on a system with GNU
>>> userland, and no luck -- GNU make won't help unless you patch it.
>> GNU make will never set the shell from the environment.
>> I've built wmii on Solaris without problems using
>> gmake SHELL=/bin/bash
>> -David
> Hello David,
> you mentioned you compiled wmii successfully on Solaris.

Yeah, I'm afraid I wrote that... that was obviously a bit premature.

Here's the thing: That was some time ago with an older wmii version. It
may be that that box was running its own Xfree86, I'm actually not sure
why it worked. I'm sorry that I can't help you further with that.

Received on Mon May 31 2010 - 18:17:24 UTC

This archive was generated by hypermail 2.2.0 : Mon May 31 2010 - 18:36:02 UTC