Re: [dev] surf 0.4 tries to free an invalid pointer

From: Kris Maglione <>
Date: Wed, 2 Jun 2010 17:15:05 -0400

On Wed, Jun 02, 2010 at 10:56:02PM +0200, Pierre Chapuis wrote:
>On Tue, 1 Jun 2010 17:13:18 -0400, Kris Maglione <>
>> On Tue, Jun 01, 2010 at 10:56:34PM +0200, Pierre Chapuis wrote:
>>>I installed surf 0.4 on Arch Linux and it crashed when I tried to click
>>>on a link to a binary file (actually to its own archive on suckless'
>>>website). Downloading with the right click menu works fine.
>>>I have copied its output below. The crash looks linked to Java.
>> Try running it under valgrind.
>I have attached the output of:
> valgrind -v --leak-check=full --show-reachable=yes surf &>
>It segfaults as soon as I run it.

Ah, you're on Arch, then. They broke valgrind on gilbc 2.12/x86_64.
You'll need to grab valgrind-svn from AUR.

Kris Maglione
Good judgement comes from experience, and experience comes from bad
	--Fred Brooks
Received on Wed Jun 02 2010 - 21:15:05 UTC

This archive was generated by hypermail 2.2.0 : Wed Jun 02 2010 - 21:24:02 UTC