[dev] [wmii] modkey-2 misbehaving on dvorak keyboard after a change in wmiirc_local

From: Mr. Bougs <mrbougs_AT_gmail.com>
Date: Fri, 26 Aug 2011 19:29:31 +0200

Hello,

I'm running wmii's hg tip (rev 2788).

I just experienced a strange behaviour with the specific shortcut
$MODKEY-2 after switching from the be (azerty) to the us dvorak-intl xkb
layout. When using that shortcut, the current window seems to lose focus
(the title bar stays highlighted). When I press it again, the window
gains focus and it inputs a 2.

xev shows nothing interesting. The problem does not happen in openbox
and is independent on the definition of $MODKEY, so it must be wmii's
fault somehow.

I had inserted these few lines into wi_events in my wmiirc_local:

   #Additional tag shortcut for 0
   Key $MODKEY-twosuperior
       wmiir xwrite /ctl view "0"
   Key $MODKEY-Shift-twosuperior
       wmiir xwrite /client/sel/ctl tags "0"

The key is the upper left key on belgian keyboards, to the left of 1.
Everything worked fine on the belgian layout. Commenting these lines out
made MODKEY-2 work as expected on dvorak.

Since I don't need this specific twosuperior shortcut on a dvorak
keyboard, this does not bother me, but I thought it was a strange enough
behaviour to be worth mentioning here.

Should I submit this to the bug tracker, or does it need more info?

Thank you for your attention,
Mr. B
Received on Fri Aug 26 2011 - 19:29:31 CEST

This archive was generated by hypermail 2.2.0 : Fri Aug 26 2011 - 19:36:03 CEST