[dev] Better naming for arg.h API

From: Nikita Zlobin <nick87720z_AT_gmail.com>
Date: Mon, 5 Jul 2021 14:48:10 +0500

For now all names in arg.h use ARG for prefix.
However, considering existing argv parsing helpers like getopt, there
could be two prefixes:
OPT - for option key or name (for long opts)
ARG - optional option value if any, argument.

This way I could propose alternated naming, which would be more clear
just by reading names in this header file:

# Is 'C' in the end of ARGC to specify it's short opt?
# If so, this means possible OPTS implementation
# (single argv field, representing opts sequence,
# would be OPTV in this case)

- ARGBEGIN ARGEND ARGC
+ OPTBEGIN OPTEND OPTC

# Same, why 'F' in the end?
- EARGF ARGF ARGF_
+ EARG ARG ARG_
Received on Mon Jul 05 2021 - 11:48:10 CEST

This archive was generated by hypermail 2.3.0 : Mon Jul 05 2021 - 12:00:08 CEST