[dev] [st] Rendering issue on Ubuntu 20.04

From: Ömer Sinan Ağacan <omeragacan_AT_gmail.com>
Date: Mon, 26 Jul 2021 09:29:23 +0300

Sorry if this is already reported/ known issue. I've tried searching for it but
couldn't find anything relevant.

I've recently updated my system from Ubuntu 18.04 to 20.04. When I build commit
2ec571a (current head of master) backspace does not work properly on 20.04. To
reproduce, just type something in a shell (I've tried with bash and zsh) and
then press backspace. It doesn't delete the characters but instead inserts a
space. So for example, if the prompt is like (`_` is the cursor)

    $ asdf_

and I press backspace twice, I see this:

    $ asdf _

Note that this is only visually, the buffer is updated as expected so if I
press enter the command I run is "as" and not "asdf ".

Anyone know if there's already a patch to fix this?


Received on Mon Jul 26 2021 - 08:29:23 CEST

This archive was generated by hypermail 2.3.0 : Mon Jul 26 2021 - 09:00:09 CEST