Re: [dwm] Fibonacci in 4.8?

From: Ruben Gonzalez Arnau <ruben_AT_websbarcelona.com>
Date: Wed, 26 Mar 2008 18:29:12 +0100 (CET)

> On Wed, Mar 26, 2008 at 05:13:05PM +0100, Ruben Gonzalez Arnau wrote:
>> > Hi,
>> > I'm a new dwm user and I'm trying to get the fibonacci layouts, but
>> the
>> > patch is only for 4.6 -- I tried simply including the fibonacci.c file
>> > in config.h and adding the layouts, but I'm getting errors when I
>> > compile dwm:
>> >
>> > In file included from config.h:2,
>> > from dwm.c:230:
>> > fibonacci.c: In function ‚€˜fibonacci‚€™:
>> > fibonacci.c:6: error: ‚€˜wax‚€™ undeclared (first use in this
>> function)
>> > fibonacci.c:6: error: (Each undeclared identifier is reported only
>> once
>> > fibonacci.c:6: error: for each function it appears in.)
>> > fibonacci.c:8: error: ‚€˜waw‚€™ undeclared (first use in this
>> function)
>> > fibonacci.c:9: error: ‚€˜wah‚€™ undeclared (first use in this
>> function)
>> > fibonacci.c:13: error: ‚€˜Client‚€™ has no member named ‚€˜ismax‚€™
>> > fibonacci.c:44: error: ‚€˜way‚€™ undeclared (first use in this
>> function)
>> >
>> > My C isn't that good, so could somebody help me getting this to work,
>> > if it's not too much trouble? Thanks :)
>> >
>> > Cheers, Valentin
>> >
>> >
>> In anyway, if you don't use xinerama you can still using dwm 4.7 and the
>> patch for 4.6 it will work.
>>
>> On the other hand, dwm 4.8 is great :)
>
> Well, to be honest I don't recommend using 4.8 anymore, use hg
> tip. 4.9 will be released quite soon.
>
> Kind regards,
> --
> Anselm R. Garbe >< http://www.suckless.org/ >< GPG key: 0D73F361
>
>
Yes, for the first time users, I think that <= 4.7 or 4.9 is more 'dwm'.

I am still using 4.7, waiting for 4.9 :D

Thanks for work and your patience.
Received on Wed Mar 26 2008 - 18:29:45 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 15:28:53 UTC