[dwm] ShiftMask not working

From: Ђорђе Тодоровић <st.dzordz_AT_gmail.com>
Date: Sun, 15 Mar 2009 13:52:46 +0100

Help, I can't get ShiftMask to work with my key definitions. I'm using dwm-5.4.1 with default config.h

Problem: When I try to use key definition that has ShiftMask in it, nothing happens.

These are my modifier bindings:
$ xmodmap
xmodmap: up to 3 keys per modifier, (keycodes in parentheses)

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x6d)
mod1 Alt_L (0x40), Alt_L (0x7d), Meta_L (0x9c)
mod2 Num_Lock (0x4d)
mod4 Super_L (0x7f), Hyper_L (0x80)
mod5 Mode_switch (0x5d), ISO_Level3_Shift (0x7c)

I tried binding Shift_L to mod3 to see if i can get it to work as a modifier at all, that works,
but only if I remove it from all other modifiers (which sadly, disables it's normal use for capitalising letters):

$ xmodmap -e "add mod3 = Shift_L
$ xmodmap -e "remove shift = 0xffe1"

now I can user Mod3Mask in my config.h, but ShiftMask still won't work.

I also tried several other versions of dvm and some of it's derivates (xmonad and others) and the problem is still there.
Received on Sun Mar 15 2009 - 12:52:46 UTC

This archive was generated by hypermail 2.2.0 : Sun Mar 15 2009 - 13:00:05 UTC