Re: [hackers] [quark] Use sizeof() instead of magic constants || FRIGN

From: FRIGN <dev_AT_frign.de>
Date: Mon, 5 Sep 2016 09:59:20 +0200

On Mon, 5 Sep 2016 09:55:49 +0200
Anselm R Garbe <garbeam_AT_gmail.com> wrote:

Hey Anselm,

> Beware! There have been zealots arguing that using goto is a bad
> practice for similar reasons.
>
> typedef's have to be considered more carefully.

zealots argue against goto because it's a low-level feature and they
have not understood that loops are basically using goto under the hood.
So we can identify the notion against goto as the fear of low-level
stuff and a fear of low-abstraction.

With typedefs, we are going another direction, because typedefs are a
"high-abstraction" just like using

if () {

} else if () {
        if () {

        } else {

        }
}

trees just not to have gotos in the code.

Cheers

FRIGN

-- 
FRIGN <dev_AT_frign.de>
Received on Mon Sep 05 2016 - 09:59:20 CEST

This archive was generated by hypermail 2.3.0 : Mon Sep 05 2016 - 10:00:40 CEST