Re: [hackers] About swapfocus dwm patch

From: Daniel Littlewood <>
Date: Wed, 30 Sep 2020 08:45:09 +0100

Hi Vinicius,

I think the "patch does not apply" error may be a red herring. The
patch applies cleanly for me directly to dwm 6.2, but does not
    dwm.c:2161:52: error: ‘Monitor’ {aka ‘struct Monitor’} has no
member named ‘pertag’
On the other hand, the patch conflicts you get if you apply pertag
first are caused by the swapfocus patch including parts of pertag in
its diff. I tried removing the parts of pertag that swapfocus
includes, but could not get something compilable.

I would probably check with the maintainer, but there could be a fix
I'm not seeing.

All the best,

On Wed, Sep 30, 2020 at 6:54 AM vinícius mota <> wrote:
> Thank you very much Chris for your reply.
> I just tried again, from scratch, and failed again, with the same error. Early on today I successfully installed other suckless patches, this time for st, following the same procedure and everything worked flawlessly. In fact since I have two other patches for dwm in place, everytime dwm is reinstalled those two patches are reinstalled as well, and that happened several times today.
> It may be nonsense but I have looked up several patches' codes today and noticed that the beginning of the swapfocus patch is different, with a different "diff" command:
> diff -up a/config.def.h b/config.def.h
> --- a/config.def.h 2020-01-29 00:06:12.415681126 +0100
> +++ b/config.def.h 2020-01-29 13:25:14.167910093 +0100
> _AT_@ -66,6 +66,7
> while for all others that I have looked in such as hide vacant tags the diff command reads
> diff --git a/dwm.c b/dwm.c
> index 4465af1..c4aa3de 100644
> --- a/dwm.c
> +++ b/dwm.c
> _AT_@ -416,7 +416,7 @@
> Other than that I have no idea of why it is failing the way it is.
> Anyway, thank you again very much for your reply.
> Vinícius.
> --
> Fingerprint: 1224546E7D5435465E1777CB8E65EA37669D90BE
> Long Key ID: 8E65EA37669D90BE
> Short Key ID: 669D90BE
> On Tue, Sep 29, 2020 at 10:29 PM Chris Down <> wrote:
>> Hi Vinícius,
>> The error message from patch is quite clear that it failed to apply, so
>> compilation is premature. You need to either massage it in, or find a patch
>> which roughly matches your version.
Received on Wed Sep 30 2020 - 09:45:09 CEST

This archive was generated by hypermail 2.3.0 : Thu Oct 01 2020 - 12:48:33 CEST