Re: [wmii] Snapshot release of 3.5 - Does not work!

From: Vincent <10.50_AT_free.fr>
Date: Sat, 13 Jan 2007 22:31:32 +0100

Anselm,

> I assume a broken compiler or Xlib here. The debugging process
> looks as follows:
[]

> Also consider a broken Xlib or a broken compiler.

Sorry for being late to answer.
Happy new year to all. Frohlig Neujahr.

Things are really strange. When I execute dwm or wmii from console, it
just gives nothing. At the first key-combination event, it blocks, and
goes dead. Nothing can be done (keyboard and mouse do not respond)
except emergency exit through CTRL-ALT-BACKSPACE.

Now, when I execute dwii from ttyE1 instead of console (the first
virtual terminal), situation is altered. No keypress work at start, but
mouse is active and remains active even after several keypresses. If I
now type CTRL-ALT-F1, as if I wished to return to console, nothing
happens (no screen switch) but suddently the keyboard is woken up, so
dwm works also. Well, at least for while, since after a random but
relatively short time, X crashes. That is to say, I do not lose screen,
but once again, everything freezes, even the mouse, and I cannot even
escape with CTRL-ALT-BACKSPACE. Yet, I am still able to shut down
properly by pressing the power switch, which leads me to be sure that
the kernel runs normally.

Wmii seems to be dead whatever I do, console or ttyE1.

I thought I'd be able to get gdb info by having to virtuals terminals on
my screen and switch back and forth, but obviously that won't work. So
I'll have to set up another box to get gdb running through a remote login.

Have a nice Sunday
Vincent
Received on Sat Jan 13 2007 - 22:31:47 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 16:18:24 UTC