Re: [dev] Re: wmii; make with /bin/bash not with /bin/sh

From: David Schmid <>
Date: Mon, 31 May 2010 14:09:54 +0200

David Engster wrote:
> Robert Ransom writes:
>> On Thu, 20 May 2010 14:51:37 +0200
>> David Schmid <> wrote:
>>> Measures tried:
>>> - resetting PATH, since make calls /bin/sh and not sh it is never
>>> looked up there
>>> - setting BINSH or SHELL to /bin/bash won't work either.
>>> - Asking for help at #suckless did not come up with immediate solution.
>> I just tried "SHELL=/bin/echo make foo.o" on a system with GNU
>> userland, and no luck -- GNU make won't help unless you patch it.
> GNU make will never set the shell from the environment.
> I've built wmii on Solaris without problems using
> gmake SHELL=/bin/bash
> -David
Hello David,

you mentioned you compiled wmii successfully on Solaris.
Could it be, that Solaris 10 does not have Xutf8* functions?
That's the only thing LD is missing right now and I can't find the libs
to link it against.
Do I have to patch all the UTF-8 functions (like
Xutf8TextPropertyToTextList to XmbTextPropertyToTextList) or what did
you do?

Received on Mon May 31 2010 - 12:09:54 UTC

This archive was generated by hypermail 2.2.0 : Mon May 31 2010 - 12:12:02 UTC