Re: [dev] cannot run st

From: Christoph Lohmann <>
Date: Thu, 24 Jan 2013 19:46:30 +0100


On Thu, 24 Jan 2013 19:46:30 +0100 pancake <> wrote:
> i've been quite busy these last months.. so i was a little disconnected
> from the suckless development... but several months ago i tried to run
> st on OSX without success.. and today i tried to run it on linux
> (voidlinux) without much more luck.

I am sorry to distract you from maintaining your ego.

> I get the same error on both systems, but looks like it works on Ubuntu
> and other bloatware distros, so i guess there's something in st that
> dislikes distros from scratch.
> I asked in the irc, but nobody helped there, looks like i'm the only
> retarded with that problem, but it's quite anoying, mostly because it's
> the only program i have problems to run. i use terminals every day
> without any single issue, and i tried to run rxvt, xterm, vte, ... and
> all them work just fine.

Two years ago I had respect for your experience in software and debug‐
ging. But this seems long gone. You are telling me nothing in the last
sentences, except that noone cared for your ego and suckless should
fucking care for you because you are you. Have you really forgotten your
roots and are now a Mac OS X dumbass that wants everything now. IRC is
not for sissies.

Btw. »works (in all of them) just fine« is no fact that gets to any so‐
lution. So forget that kind of argumentation for the rest of your life.
No, it never works and only annoys me to fix your bug.

> The error I get is this:
> $ st
> XOpenIM failed. Could not open input device.
> So.. I tried to find the bug and here it is:
> run:
> //setlocale(LC_CTYPE, "");
> XSetLocaleModifiers("");
> tnew(80, 24);
> just commenting the setlocale() makes st to run, so XOpenIM fails
> because of that. (wtf)

As said above: You’ve lost your whole experience to dig deeper into
problems. Please try to find back to your old skills and debug down to
X11 why your X11 input method fails to initialize. This might help to
find a better solution than to comment out random functions not directly
connected to the problem.

> I guess this is not the correct solution, what is the purpose of this
> setting the locales?

Tell me. This is suckless and not your Vala or Gtk support forum for
people without any principles.

> PD: the default font is not installed on OSX by default and without
> antialias it looks like crap

Thanks for suggesting a better font. Now I can really find out how to
fix this because everyone owns Mac OS X in your small world. No, there
are people that do not own Mac OS X and will never own Mac OS X. Thanks
for wasting my time.

> PD: i wrote a terminal image viewer (tiv) just to have fun with some
> ascii-art rendering algorithms, so i did it in Vala and uses Gdk to load
> images (yeah, i will rewrite it in C at some point, but just wanted to
> do it fast and focus in the image processing code). The program renders
> the pictures in plain text, ansi16, greyscale and ansi256. Works fine in
> st :) you may find the source here:

For short: You will never rewrite it because you will never find any
time to do so. But you did it in some obscure language and try to infil‐
trate suckless computers with your shortcomings of C inexperience and
not working time management. Thanks for wasting my time with your bloat.
I really get horny when I see long commandline options.


Christoph Lohmann
Received on Thu Jan 24 2013 - 19:46:30 CET

This archive was generated by hypermail 2.3.0 : Thu Jan 24 2013 - 20:00:05 CET