Re: [dev] [st] mouse up scrolling not working in vim through tmux in st

From: Jay Rajput <>
Date: Sun, 1 Jun 2014 12:38:24 -0400

Verified. The changes have solved the problem. Both scroll up and down
are working for me. I am testing on code from the git repo.

[root_AT_work st]# sed -ne '829,833{p}' st.c
                        /* MODE_MOUSEX10: no button release reporting */
                        if (button == 64 || button == 65)

Thanks all for the quick fix.

On Sun, Jun 1, 2014 at 9:58 AM, Christoph Lohmann <> wrote:
> Greetings.
> On Sun, 01 Jun 2014 15:58:13 +0200 Balazs Kezes <> wrote:
>> On 2014-05-31 20:35 +0530, Jay Rajput wrote:
>> > Problem Statement: Mouse up scrolling not working in vim through tmux
>> > in st. Mouse down scrolling works fine.
>> Thou shall not report release events for mouse wheel events. I think
>> neither tmux, neither vim handles these gracefully. For some reason the
>> release events are interpreted as scroll down in vim-in-tmux. So
>> scolling down actually scrolls down twice and scrolling up is
>> interpreted as a scroll up followed by a scroll down.
> I applied your patch. Please all comment back if the problems are now
> solved. I don’t have a scrollwheel.
>> Sidenote: while looking at tmux under st I experienced a lot of other
>> rendering problems. I suspect this is because st's VT100 emulation is a
>> bit weak. In case this is something the suckless community would like to
>> fix, I recommend using xterm's vttest[3] to test the features.
> No, that’s due to the bad vt100 emulation of tmux (tmux does vt100 in‐
> side of every tty) which assumes screen. St supported much of it, but
> diverted due to further development.
> Sincerely,
> Christoph Lohmann

Thank you,
Jay Rajput
Received on Sun Jun 01 2014 - 18:38:24 CEST

This archive was generated by hypermail 2.3.0 : Sun Jun 01 2014 - 18:48:06 CEST