Re: [dev] Misbehaving floating window in dwm

From: Michal Haško <>
Date: Thu, 3 Jul 2014 16:32:21 +0200

2014-07-03 11:59 GMT+02:00 Alexander S. <>:
> 2014-07-03 10:44 GMT+04:00 Michal Haško <>:
>> Hi all,
>> I'm new to the list, although I've been active user of dwm for 3+ years.
>> There's this misbehaving program whose window I cannot move whatsoever.
>> xprop-ing the window doesn't report any wm_class, which is by itself
>> weird. In other window managers (kwin) the window behaves properly,
>> can be moved (but not resized, which is by design, you'll see if you
>> try it).
> From quick code digging, it seems that moving and resizing both call
> XConfigureWindow with
> CWX|CWY|CWWidth|CWHeight|CWBorderWidth [0]. If the application in
> question is simply
> ignoring all events that look even remotely like resizing, without
> applying the movement part,
> that would explain this behaviour.
> While separating resize and move is indeed possible, its a workaround
> for what I'd call...
> not sane behaviour, and also extremely not common case. My guess is
> that it won't be fixed.
> Try writing to Pianoteq support, maybe they'll file a bug about it.
> For quickly confirming it, you can replace the mask in question with
> CWX|CWY, that'll produce
> version of DWM incapable of resizing windows, but you'll be able to
> test if it moves then.

Thanks for the tip. I've tried it, but it didn't work.

I don't mean to spread hate, but I've tried pianoteq under xmonad and
awesome, and didn't have this issue... It saddens me that dwm can't
handle it, but other window managers can. This might be a deal breaker
to me.


> [0]
> --
> Best regards,
> Alexander Sedov.
Received on Thu Jul 03 2014 - 16:32:21 CEST

This archive was generated by hypermail 2.3.0 : Thu Jul 03 2014 - 16:36:04 CEST