RE: [dev] [abduco] Read-only connect to session from other user

From: Ben Golding <>
Date: Thu, 14 Aug 2014 19:16:55 +0000

Hi Marc,

Indeed, changing the socket perms to 777 does allow the other user to connect.

As you pointed out, '-ar' behaves as '-a', connecting in read-write mode without any warning.
Using '-a -r' connects in read-only mode.
So now someone has tried it :)

> > As the other user, I run 'abduco -ar ~bgolding/${HOSTNAME}.abduco'
> ^
> I think here is your problem, ~ will expand in the context of your
> second user whereas the socket was created in the home directory of
> the first user.

AFAIK ~bgolding expands to bgolding's home dir, regardless who is the current user....

  % echo ~ ~ccmaster ; echo ~invalid
  /remote/de02h21/bgolding /remote/de02h27/ccmaster
  Unknown user: invalid.

So far I found abduco a good replacement for dtach (not that I had any issues with dtach).
The only difference I noticed, my screen doesn't refresh on connect. I need to hit Ctrl-L.
I guess this might be a result of a deliberate design decision:
" only supports 1 redraw mechanism (based on SIGWINCH) instead of 3..."

Received on Thu Aug 14 2014 - 21:16:55 CEST

This archive was generated by hypermail 2.3.0 : Thu Aug 14 2014 - 21:24:06 CEST