Re: [dev] [bug] locked mouse pointer

From: Andrew Fuller <>
Date: Fri, 22 Apr 2016 12:38:06 -0700

I ran into the same issue about a week ago, using i3wm+st. Exactly the
same symptoms as you described, and it's the first time it's ever
happened to me. Unfortunately I "fixed" it by unplugging/replugging my
house and I don't know how to reproduce it. But I haven't restarted
any software or rebooted since then, so the problem should still exist
on my setup. Let me know if I can help you track this down.


On Fri, Apr 22, 2016 at 9:49 AM, Alba Pompeo <> wrote:
> Dears,
> I have a weird bug and I'm not sure how to find the culprit.
> I'm using dwm and from time to time my mouse pointer gets locked.
> Highlighting text on st doesn't work, right-clicking on firefox
> doesn't work, left-click dragging on pdf-reader doesn't work, slock
> errors, windows don't get focused and other clumsy things. When I
> restart X the problem is solved, but it soon happens again.
> I'm very lost as what's the cause of this.
> I tried logging dwm's stderr, but found nothing relevant there.
> The only clue I have is that when I try to run slock while the bug is
> happening, I get this message --- slock: unable to grab mouse pointer
> for screen 0
> Who could be the culprit here? dwm? xorg? driver?
> Can anyone think of a way to debug this?
> Thanks a lot.
> Ciao.
Received on Fri Apr 22 2016 - 21:38:06 CEST

This archive was generated by hypermail 2.3.0 : Fri Apr 22 2016 - 21:48:12 CEST