Re: [dev] [bug] locked mouse pointer

From: Andrew Fuller <>
Date: Mon, 25 Apr 2016 15:46:11 -0700

What versions of xorg/xinput/libinput/evdev are you on? I'm on xorg
1.15.1, xinput 1.6.1, and evdev 2.8.2.


On Mon, Apr 25, 2016 at 3:34 PM, Alba Pompeo <> wrote:
> Same here, after blacklisting libinput everything works as expected.
> But now I can't use the touchpad, which is inconvenient.
> Damn Xorg!
> On Mon, Apr 25, 2016 at 6:54 PM, Andrew Fuller <> wrote:
>> No laptop, no touchpad for me. I've got a standard USB mouse on a
>> desktop. For me the bug happened as I was toggling mplayer fullscreen
>> and back. I've done that many times since and the bug hasn't come up
>> again.
>> On Fri, Apr 22, 2016 at 12:58 PM, Alba Pompeo <> wrote:
>>> After searching for a long time, I think I found the bug report about
>>> this issue.
>>> It's really either a libinput or xorg bug.
>>> Are you using a laptop with touchpad by any chance?
>>> Blacklisting the touchpad input seems to have fixed it for me, but
>>> it's still too soon to be sure. You should give it a try and report
>>> back.
>>> Let me know if that works for you.
>>> And now I'm even more prompt to jump ship and install Wayland. Xorg is
>>> a pain in the ass.
>>> Ciao.
>>> On Fri, Apr 22, 2016 at 4:38 PM, Andrew Fuller <> wrote:
>>>> I ran into the same issue about a week ago, using i3wm+st. Exactly the
>>>> same symptoms as you described, and it's the first time it's ever
>>>> happened to me. Unfortunately I "fixed" it by unplugging/replugging my
>>>> house and I don't know how to reproduce it. But I haven't restarted
>>>> any software or rebooted since then, so the problem should still exist
>>>> on my setup. Let me know if I can help you track this down.
>>>> Andrew
>>>> On Fri, Apr 22, 2016 at 9:49 AM, Alba Pompeo <> wrote:
>>>>> Dears,
>>>>> I have a weird bug and I'm not sure how to find the culprit.
>>>>> I'm using dwm and from time to time my mouse pointer gets locked.
>>>>> Highlighting text on st doesn't work, right-clicking on firefox
>>>>> doesn't work, left-click dragging on pdf-reader doesn't work, slock
>>>>> errors, windows don't get focused and other clumsy things. When I
>>>>> restart X the problem is solved, but it soon happens again.
>>>>> I'm very lost as what's the cause of this.
>>>>> I tried logging dwm's stderr, but found nothing relevant there.
>>>>> The only clue I have is that when I try to run slock while the bug is
>>>>> happening, I get this message --- slock: unable to grab mouse pointer
>>>>> for screen 0
>>>>> Who could be the culprit here? dwm? xorg? driver?
>>>>> Can anyone think of a way to debug this?
>>>>> Thanks a lot.
>>>>> Ciao.
Received on Tue Apr 26 2016 - 00:46:11 CEST

This archive was generated by hypermail 2.3.0 : Tue Apr 26 2016 - 00:48:11 CEST