[dev] first batch of renames pushed, but the new name scheme is somewhat bad...

From: Britton Kerin <britton.kerin_AT_gmail.com>
Date: Fri, 8 Jul 2016 13:14:30 -0800

I just pushed a commit which renames a bunch of stuff like so:

dwm-6.1-uselessgap.diff => dwm-uselessgap-6.1.diff
dwm-cdec978-alwaysfullscreen.diff =>

This was the agreed format but in a way it's a change for the worse.
It splits the thing patched against (prog+version) into two parts and
puts the patch name in between. To see why this is bad consider
http://st.suckless.org/patches/scrollback which stacks some patches on
top of each other to get different behaviors. Obviously we want the
patches to be mostly flat but that use case is reasonable.
It would be better to be consistent st


was instead:


This way things appended to the base name always represent
modifications of what comes before.

There are still lots of renames that have to be made by hand, broken
patches to contend with, etc. but I thought I'd ask one more time if
we're sure we're happy with this naming scheme.

Received on Fri Jul 08 2016 - 23:14:30 CEST

This archive was generated by hypermail 2.3.0 : Fri Jul 08 2016 - 23:24:11 CEST