Re: [dev] Failed to open file “/var/lib/dbus/machine-id”: Permission denied

From: Jochen Sprickerhof <>
Date: Fri, 19 Jul 2019 23:56:55 +0200

Hi Piotr,

* Piotr Martyniuk <> [2019-07-18 15:09]:
>I recently updated to Debian 10 x64 and tried to open local html file
>with surf. But when I do this I get the following error:
>$ surf info.html
>(surf:24332): IBUS-WARNING **: 15:06:50.866: Unable to load
>/var/lib/dbus/machine-id: Failed to open file
>“/var/lib/dbus/machine-id”: Permission denied Error receiving IPC
>message on socket 20 in process 24340: Connection reset by peer
>When I check the permissions to the mentioned file, then I see that it
>should not be a problem to read it as all users has read permission:
>$ ls -l /var/lib/dbus/machine-id
>-rw-r--r-- 1 root root 33 Apr 27 13:38 /var/lib/dbus/machine-id
>$ surf -v
>surf-2.0, see LICENSE for © details
>So what might be a problem?

The surf version in Debian installs a apparmor profile and Debian 10
enables apparmor by default. I guess this restricts the access (but
haven't tried to reproduce it).

Cheers Jochen

Received on Fri Jul 19 2019 - 23:56:55 CEST

This archive was generated by hypermail 2.3.0 : Sat Jul 20 2019 - 04:12:10 CEST