[dev] Re: [hackers] [st] support REP (repeat) escape sequence || Avi Halachmi (:avih)

From: Greg Reagle <greg.reagle_AT_umbc.edu>
Date: Sat, 16 May 2020 15:30:36 -0400

On Sat, May 16, 2020, at 08:09, git_AT_suckless.org wrote:
> support REP (repeat) escape sequence
> This is Ecma-048/ANSI-X3.6 sequence and not DEC VT. It's supported by
> xterm, and ncurses uses it when possible, e.g. when TERM is xterm* (and
> with this commit also st*).
> To test:
> - tput rep 65 4 -> prints 'AAAA'

When I run xterm (Debian stable version 344-1) (TERM is xterm) and enter the command 'tput rep 65 4', the terminal does not print 4 A's; it prints nothing (next line is the shell prompt). Same behavior for rxvt-unicode version 9.22-6 (TERM is rxvt-unicode-256color) and xfce4-terminal version (TERM is xterm-256color) . Am I doing something wrong or misunderstanding something? Does the shell matter? My default shell is fish but I've tried with bash too.
Received on Sat May 16 2020 - 21:30:36 CEST

This archive was generated by hypermail 2.3.0 : Sat May 16 2020 - 22:12:09 CEST