Re: [dwm] st

From: John Norton <>
Date: Wed, 9 Aug 2006 00:03:46 -0500

On 00:46 Wed 09 Aug , John Gosset wrote:
> I'm unable to run as either root or non-root user (member of the tty
> group); still getting the same error message... this probably means
> the stock Arch kernel doesn't support BSD pseudo-terminals.
> John
> On 8/9/06, John Norton <> wrote:
> >On 22:42 Tue 08 Aug , Kurt Maier wrote:
> >> If you're running udev, make sure to add yourself to the tty group.
> >>
> >> Kurt
> >>
> >
> >See, I just did that, but it did not help. I have noticed, while
> >digging through /dev that I am currently using terminals /dev/pts/*
> >which are owned by me (user) with group tty, while the ptyxx and ttyxx
> >terms are owned by root, with group tty and permissions crw-rw----.
> >What would be the proper way to solve this? Should I chmod some ptyxx's
> >and ttyxx's? I doubt this is what I _really_ should do.
> >
> >Cheers,
> >
> >Jack
> >

Hmmmm I whish you where correct, but a look into my kernels config
and..... CONFIG_LEGACY_PTYS=y, which I believe coresponds to the
non-SysV pty's (i.e. the BSD ones). So I am out of ideas. I ran strace
on an execution of st under a normal user, and sure enough I got many,
many lines to the tune of "open("/dev/ptyxx", 0_RDWR) = -1 EACCESS (Permission Denied)
so it seems all that is wrong is a permissions issue, but I still don't
want to just blindly chmod tons of dev nodes just on a whim for a
terminal emulator (not yet...).
I believe I have exhausted my usefulness on this issue. I will try
again later.


Received on Wed Aug 09 2006 - 07:04:17 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 14:30:03 UTC