Hi,
attached are 3 patches:
-clean:
small cleanup of layout.c for loop in floating() - to have it same
styled as loop in tile()
-focusmerge:
merges function of focus() and focustopvisible() into one function
focus(). It has parameter Client *c and this behaviour:
- c == NULL: if selscreen then select topvisible window else
deselect sel (used in leavenotify, while pointer goes to
another screen in multihead setup).
- c && isvisible(c): focus that client
- else: select topvisible client
this makes behaviour of focus(NULL) more intuitive, the function do
the best to select the client AND everytime has some client selected
- if there is someone visible (and if selscreen, of course :). Also
allow some cleanup in layout functions, too;
-un_ban:
refactor (un)banning of (in)visible clients from layouts functions.
Their code is then more readable and it ease creation of another
layouts, too
--anydot
This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 14:43:11 UTC