Re: [dwm] slock fails

From: Antoni Grzymala <>
Date: Thu, 28 Jun 2007 19:14:37 +0200

Tako rzecze Denis Grelich (w e-mailu datowanym 2007-06-28, 18:28):

> On Tue, 26 Jun 2007 05:48:32 -0500
> G David Modica <> wrote:
> > When I invoke slock via dmenu while in an active tag, the screen
> > blanks for a scecond and then unlocks. The same thing happens if I
> > invoke slock from a terminal.
> >
> > If I invoke slock via dmenu while in an inactive tag (viewing the X
> > root window), it works as expected.
> >
> > I am using dwm-4.2 patch with bstack, but get the same result when I
> > use plain dwm-4.2.
> >
> > Any ideas?
> >
> I have similar experiences regularly. I can't alway reproduce them, but
> it's there.
> slock seems to segfault sometimes. I didn't bother looking into it yet,
> but it's definitely a problem for a security related app.

You guys may want to look into using xtrlock before slock gets fixed. I
find it perfectly adequate for my needs. There was however (about a year
ago) a problem with grabbing the keyboard by dwm and since then I've
been launching it this way:

  { MODKEY|ControlMask, XK_l, spawn, "sleep 1 && exec xtrlock" }, \

The problem might have gone away in later releases of dwm but I was
never bothered to check.

Also there's the alock Google Summer of Code project: ||

They say it's a replacement for the old xtrlock but it actually didn't
work for me at all. When I tried. See what your experiences are if you
can give it a



. Antoni Grzymala - antoni (at) -------------------.
| OpenPGP KeyID EB315583 available now from a keyserver near you |
| Fingerprint A819 6D2E D5EB D9E0 D2D9  7AF6 2FAF 4A11 EB31 5583 |

Received on Thu Jun 28 2007 - 19:14:57 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 14:45:22 UTC