hackers mail list archive by subject
- [dwm][PATCH] Set the EWMH _NET_SUPPORTING_WM_CHECK atom
- [hackers][sbase][PATCH] arg.h: fixed argv checks order
- [PATCH 01/65] FAQ: update, working bot example
- [PATCH 02/65] LICENSE: update
- [PATCH 03/65] add util functions from sbase
- [PATCH 04/65] add arg.h
- [PATCH 05/65] config.mk: update
- [PATCH 06/65] Makefile: compile with util
- [PATCH 08/65] overhaul: see CHANGES for changes
- [PATCH 09/65] check if fullname is set and non-empty
- [PATCH 1/1] tar: no mtime/chown/chmod on hard links
- [PATCH 1/2] add realpathm() to libutil
- [PATCH 1/2] Check up on server messages
- [PATCH 1/2] improve some more error messages
- [PATCH 1/2] Refactor dontkillme()
- [PATCH 1/2] Remove insane *_FILENO and EXIT_* usage
- [PATCH 1/2] tar: extract creation mode
- [PATCH 1/2] tar: read mode for all entity types
- [PATCH 1/2] vis: export vis_window_closable
- [PATCH 1/3] Localize and rework data structures
- [PATCH 1/3] Move around navigation keybindings
- [PATCH 1/3] New/fixed readlink utility
- [PATCH 1/3] Typofix
- [PATCH 1/4] Clean-up error messages
- [PATCH 1/4] ed: newly joined lines are placed correctly
- [PATCH 1/5] drw: simplify color schemes
- [PATCH 1/5] ed: remove infinite loops in join() and getindex()
- [PATCH 1/5] Remove insane *_FILENO and EXIT_* usage
- [PATCH 10/65] check if host and nick are non-empty
- [PATCH 11/65] fix: use global ircfd, dont send to c->fd
- [PATCH 12/65] LICENSE: add myself
- [PATCH 13/65] stylistic fixes
- [PATCH 14/65] initialize some variables
- [PATCH 15/65] fix possible out of bounds with empty string ""
- [PATCH 16/65] ii.1: show version in man page
- [PATCH 17/65] print_out: compare at start of line...
- [PATCH 18/65] time format %Y-%m-%d %H:%M is more familiar
- [PATCH 19/65] separate get_filepath() from create_filepath()
- [PATCH 2/2] check memory allocation for calloc, die on failure
- [PATCH 2/2] Convert manpage to mandoc and fix usage
- [PATCH 2/2] Fix channel use after freeing in main loop
- [PATCH 2/2] restore readlink -e and -m flags, add realpath
- [PATCH 2/2] tar: improve file status handling on extract
- [PATCH 2/2] tar: set mode directly on new files
- [PATCH 2/2] Unboolify st
- [PATCH 2/2] vis: implement gf and <C-w>gf to open filename under cursor
- [PATCH 2/3] missing ret values
- [PATCH 2/3] Move urgent keybindings from u to /
- [PATCH 2/3] Rename getpw() and pws to gethash() and hash
- [PATCH 2/4] Add 'n' and 'p' key for next and previous slide
- [PATCH 2/4] ed: if only one address is given to j, do nothing.
- [PATCH 2/5] drw: fixup drw_rect function
- [PATCH 2/5] ed: giving j only one address does nothing
- [PATCH 2/5] Unboolify st
- [PATCH 20/65] stylistic changes
- [PATCH 21/65] don't exit if a channel can't be created
- [PATCH 22/65] remove infile when leaving a channel
- [PATCH 23/65] write global messages to the correct fd (bug from cleanup)
- [PATCH 24/65] warn about keyname password if it can't be found
- [PATCH 25/65] prefix errors with "ii: "
- [PATCH 26/65] add comment about ipv6
- [PATCH 27/65] man page: update format
- [PATCH 28/65] update CHANGES
- [PATCH 29/65] remove obsolete gethostbyname, use getaddrinfo (adds support for IPV6)
- [PATCH 3/3] Move kill window keybinding from q to -
- [PATCH 3/3] remove unnessecary assignment
- [PATCH 3/3] Stop using $USER for shadow entries
- [PATCH 3/4] ed: fix double free and infinite loop in join().
- [PATCH 3/4] Use background color from color scheme for PNGs
- [PATCH 3/5] Align struct members
- [PATCH 3/5] drw: fixup font handling
- [PATCH 3/5] ed: place newly joined lines correctly
- [PATCH 30/65] update man page: this was not supported
- [PATCH 31/65] add a note about ssl/tls protocol support
- [PATCH 32/65] dont print perror
- [PATCH 33/65] minor doc changes
- [PATCH 34/65] restore old key behaviour
- [PATCH 35/65] FAQ: example, treat backslash normally
- [PATCH 36/65] config.mk: dont bump version just yet
- [PATCH 37/65] Makefile: fix make dist, add util.h and arg.h
- [PATCH 38/65] Makefile: clean util/*.o and util.a
- [PATCH 39/65] strlcpy code style
- [PATCH 4/4] ed: wrote manpage
- [PATCH 4/4] Replace duplicate code with eprintf call
- [PATCH 4/5] drw: misc fixes
- [PATCH 4/5] ed: remove double free in join()
- [PATCH 4/5] Make style consistent
- [PATCH 40/65] simplify some more
- [PATCH 41/65] overhaul v2
- [PATCH 42/65] fix channel reopen
- [PATCH 43/65] improve
- [PATCH 44/65] strncmp -> strcmp + code-style
- [PATCH 45/65] fix signed / unsigned type warning
- [PATCH 46/65] config.mk: improve, remove solaris, noone uses it
- [PATCH 47/65] CHANGES: document timestamp change
- [PATCH 48/65] cast to unsigned long, thanks sin!
- [PATCH 49/65] add quit command (/q)
- [PATCH 5/5] drw: fixup drw_text
- [PATCH 5/5] ed: add manpage
- [PATCH 5/5] Make config.def.h more consistent
- [PATCH 50/65] raw IRC output to stdout
- [PATCH 51/65] code style, increase IRC channel buffer size
- [PATCH 52/65] cleanup master channel on quit or exit
- [PATCH 53/65] close all channels on exit (removes "in" files)
- [PATCH 54/65] update CHANGES
- [PATCH 55/65] add support to connect to unix domain socket
- [PATCH 56/65] cleanup
- [PATCH 57/65] clear timeval struct, don't use invalid wrset
- [PATCH 58/65] set fd to -1 on close
- [PATCH 59/65] bump version to 1.8 but dont show it in usage() anymore
- [PATCH 60/65] channel_open: don't close previous fd here
- [PATCH 61/65] small cleanup: check uds pointer, dont assign empty value, ty FRIGN
- [PATCH 62/65] Fixing a few details
- [PATCH 63/65] remove duplicate word, thanks Michael Stevens!
- [PATCH 64/65] Merge 2015-2016 patches in
- [PATCH 65/65] Whitespace changes
- [PATCH] a shortcut to toggle the mouse cursor
- [PATCH] Add 'realpath' utility
- [PATCH] Add .ff and .ff.bz2 to filter rules
- [PATCH] Add last(1) manpage
- [PATCH] add option to reverse the list and put prompt under it
- [PATCH] Attune example to classical axiomatics
- [PATCH] clear passwords with explicit_bzero
- [PATCH] Continue style fixing: function declarations, code alignement
- [PATCH] cp: add -i flag
- [PATCH] Created od, with improvements suggested by FRIGN
- [PATCH] Created od.
- [PATCH] Default to -ansi and declare at top of block
- [PATCH] disable bold, italic and roman fonts globally
- [PATCH] Ensure Polyphemus-Mitigation and properly drop privileges
- [PATCH] fix incorrect ordering of match results
- [PATCH] fix Mod-C and eliminate redundant shell process
- [PATCH] Fix prefix match is treated as exact match
- [PATCH] Fix type for write(2) return variable.
- [PATCH] Fix typo in variable name
- [PATCH] fix uninitialized value after include(), fixes test001
- [PATCH] Fixed typo introduced by shared code
- [PATCH] Forsake sockets for standard input/output
- [PATCH] highlight today
- [PATCH] import new drw and util from libsl.
- [PATCH] import new drw from libsl and minor fixes.
- [PATCH] Improve dmenu with prompt and a font
- [PATCH] libutil: fix leaks
- [PATCH] load slide image on-demand
- [PATCH] Makefile: move libraries to end of command; rename filename having a colon
- [PATCH] merge ffread and ffopen into one function
- [PATCH] New/fixed readlink utility
- [PATCH] od: added -t option
- [PATCH] od: added options -b and -d; bug fix affecting size C
- [PATCH] od: added support for different size values
- [PATCH] od: bugfix: "\v" was omitted from output of type 'c'
- [PATCH] od: document skip (-j) option
- [PATCH] od: more accurate statement of compliance with POSIX
- [PATCH] od: properly concatenate multiple file arguments
- [PATCH] Properly receive and respond to presence notices.
- [PATCH] Refactor main()
- [PATCH] Remove faulty example and add a section on security considerations
- [PATCH] Replace str[n]cpy with strlcpy
- [PATCH] Revert "Get rid of getkbdevice"
- [PATCH] search path for executables
- [PATCH] st.info: replace the acsc entry from xterm to urxvt
- [PATCH] Support farbfeld as an intermediate format
- [PATCH] Support xterm Ms feature to set clipboard
- [PATCH] Treat addresses of 0 as 1 for insert
- [PATCH] use goto in xloadfonts()
- [PATCH] Use switch for fork()
- [PATCH] Wrapper for xterm to fix missing .terminfo.
- [surf-webkit2] Change default font size to 16px (12pt)
- ignore ii and util.a
- Last message date: Thu May 11 2017 - 00:38:11 CEST
- Archived on: Thu Nov 21 2024 - 10:24:42 CET