Re: [wmii] Cygwin problem

From: Ajeetpal Grewal <>
Date: Mon, 29 Jan 2007 21:28:23 +0530

On Sun, Jan 28, 2007 at 09:11:38PM +0100, Anselm R. Garbe wrote:
> On Sun, Jan 28, 2007 at 04:48:13AM +0530, Ajeetpal Grewal wrote:
> > Hi everyone,
> >
> > I have a working copy of wmii on my linux box.
> >
> > On Cygwin however, there are some issues. First I could not create a directory on cygwin with the character ":" in the name. This is the default implementation in the wmii script. I got an error like this
> >
> > wmiiwm: can't stat namespace directory "/tmp/ns.AjeetpalGrewal.:0/": No such file or directory
> Yes, that's because Windows does not support the ':' character
> > I changed this to just use /tmp/ns.AjeetpalGrewal/ as the directory. However, when I try to do "wmiir ls /" I get "ixpc: connot connect to server". Although I see the status bar at the bottom of my screen, the rest of the functionality is missing, for example none of the menus pops up ( i have dmenu installed), neither can I use the modifier keys.
> >
> > What could be the problem? The implementation does not seem to depend on the ":" occurring in the directory name. Does anyone have a workaround???
> Simply edit PREFIX/bin/wmii and change WMII_NS_DIR to something
> which does not includes the ':' character.

I have tried this already. I probably wasn't clear in my initial email. I edited the wmii script to point to /tmp/ns.AjeetpalGrewal/. So there is no longer a ":" character in the folder name. Now when I run wmii, I can see that this folder is created. I also see the status bar at the bottom of the screen with the date and everything. However, nothing else works. I mentioned the change in the folder name because I thought it might be important in debugging this problem.

> Regards,
> --
> Anselm R. Garbe >< >< GPG key: 0D73F361
Received on Mon Jan 29 2007 - 16:58:18 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 16:20:09 UTC