[wmii] Bug: Resize/move window under Xvnc

From: <kp_AT_rixmail.se>
Date: Tue, 13 Mar 2007 23:53:39 +0100 (CET)

Windows in floating mode behave very strange when running the wmii-20070304 snapshot under Xvnc. They can be moved properly using the small rectangle in the upper left corner and resizing works using Mod1-Right-MB-Drag.

But if I use Mod1-Left-MB-Drag the window moves downwards to the left corner independent of in which direction I move the mouse. It finally ends up showing an ~16x16 pixel portion of the window in the lower left corner of the screen. (Sometimes it has also moved to the upper left or upper right corners of the screen. Seems to be random...)

Resizing a window using the borders does not work either (nothing happens). Furthermore the mouse pointer changes shape to the "resize" pointer even though the pointer is somewhere in the middle of the window.

All this happens when I run wmii under Xvnc with any VNC client on Windows (haven't tried a VNC client on Linux). When I switch to run wmii under X on the same computer it works just fine. Is this a bug in wmii or Xvnc? I have tried to install RealVNC/Xvnc 4.0 and TightVNC/Xvnc 1.3.8 but with the same results. I have not noticed such behaviour with other window managers that I have tried (ratpoison, ion, fluxbox or windowmaker).

Here is some more information about the distribution I run if it may help:

Topologilinux 6.0 (Slackware 10.2 with Colinux 0.6.3)

Received on Tue Mar 13 2007 - 23:54:04 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 16:23:40 UTC