Re: [dev] wmii; make with /bin/bash not with /bin/sh

From: David Schmid <>
Date: Thu, 20 May 2010 20:40:38 +0200

So, I don't know your rules around here so I hope I don't hurt your
netiquette with this eMail. Please don't kill me.
Even though someone warned me, that the suckless community _is_ good,
I am quite slightly overwhelmed by the many reactions. Thank you.

Robert Ransom <> wrote:

> I just tried "SHELL=/bin/echo make foo.o" on a system with GNU
> userland, and no luck -- GNU make won't help unless you patch it.
> Can you chroot?

Yes, I can chroot, but it seems I cannot do something useful with it
with my knowledge :/ I have a slight idea, but I am not sure if I could
damage the system. If I (mount) bind the folders
(like /bin, /share, ...) on a local folder and then chroot there;
relink sh to bash, compile, exit jail and be happy with a compiled
wmii, but a slightly damaged system this would not be what I had in

David Engster <> wrote:

> GNU make will never set the shell from the environment.
> I've built wmii on Solaris without problems using
> gmake SHELL=/bin/bash

seeme like using "make SHELL=/bin/bash" instead of "SHELL=/bin/bash
make" _does_ make a difference. Now this is something new for me. Now
it says:

MAKE all libbio/
../util/compile: syntax error at line 13: `(' unexpected
make[1]: *** [bbuffered.o] Error 2
make: *** [dall] Error 2

Same with ksh.

Kris Maglione <> wrote:

> Sorry, I've just reread this. Can you tell me exactly which scripts
> fail to run under Solaris' sh? It might help to run
> noisycc=1 make
> and post the output.

output isn't very new...

/bin/sh: bad substitution
make: *** [dall] Error 1

> for f in util/*; do
> ed $f <<EOF
> 1s/sh/bash/
> w
> done
> but I'd really rather fix it to work out of the box.

_if_ I get this right, this should substitute 'sh' for 'bash'. Tried
that already, forgot to mention this. Output is same as above.

Received on Thu May 20 2010 - 18:40:38 UTC

This archive was generated by hypermail 2.2.0 : Thu May 20 2010 - 19:12:02 UTC