[dev] cannot run st

From: pancake <pancake_AT_youterm.com>
Date: Thu, 24 Jan 2013 18:47:42 +0100

i've been quite busy these last months.. so i was a little disconnected
from the suckless development... but several months ago i tried to run
st on OSX without success.. and today i tried to run it on linux
(voidlinux) without much more luck.

I get the same error on both systems, but looks like it works on Ubuntu
and other bloatware distros, so i guess there's something in st that
dislikes distros from scratch.

I asked in the irc, but nobody helped there, looks like i'm the only
retarded with that problem, but it's quite anoying, mostly because it's
the only program i have problems to run. i use terminals every day
without any single issue, and i tried to run rxvt, xterm, vte, ... and
all them work just fine.

The error I get is this:

$ st
XOpenIM failed. Could not open input device.

So.. I tried to find the bug and here it is:

         //setlocale(LC_CTYPE, "");
         tnew(80, 24);

just commenting the setlocale() makes st to run, so XOpenIM fails
because of that. (wtf)

I guess this is not the correct solution, what is the purpose of this
setting the locales?

PD: the default font is not installed on OSX by default and without
antialias it looks like crap

PD: i wrote a terminal image viewer (tiv) just to have fun with some
ascii-art rendering algorithms, so i did it in Vala and uses Gdk to load
images (yeah, i will rewrite it in C at some point, but just wanted to
do it fast and focus in the image processing code). The program renders
the pictures in plain text, ansi16, greyscale and ansi256. Works fine in
st :) you may find the source here:


have fun

Received on Thu Jan 24 2013 - 18:47:42 CET

This archive was generated by hypermail 2.3.0 : Thu Jan 24 2013 - 18:48:05 CET