[dev] [st] problems with terminfo entries and zsh

From: <ml_AT_hxgn.net>
Date: Mon, 17 Mar 2014 12:21:10 +0100 (CET)


i use st (latest git) with the zsh and the oh-my-zsh configuration[1]. After this recent commit[2] to oh-my-zsh, several things aren't working. I only remember that the first entry worked before, but here is an overview of all things currently broken:

going to the beginning of the line with HOME:

    -bindkey "^[[H" beginning-of-line
    -bindkey "^[[1~" beginning-of-line
    -bindkey "^[OH" beginning-of-line
    +bindkey "${terminfo[khome]}" beginning-of-line # [Home] - Go to beginning of line

deleting with DEL (not sure if this worked properly before):

    -bindkey "^[[3~" delete-char
    -bindkey "^[3;5~" delete-char
    -bindkey "\e[3~" delete-char
    +bindkey "${terminfo[kdch1]}" delete-char # [Delete] - delete forward

This one i think i never used, but now i get a warning message when i load the zsh:

    -bindkey '^[[Z' reverse-menu-complete
    +bindkey "${terminfo[kcbt]}" reverse-menu-complete # [Shift-Tab] - move through the completion menu backwards

    warning: ~/.oh-my-zsh/lib/key-bindings.zsh:bindkey:37: cannot bind to an empty key sequence

I don't know if these are the results of bugs in the st.info, or if the zsh config is wrong -- any help is much apprechiated.

Best regards

[1]: https://github.com/robbyrussell/oh-my-zsh/
[2]: https://github.com/robbyrussell/oh-my-zsh/commit/7adf66f942cc143aea6ced780b249f0e989e5461#diff-79ee521883d01c4cd6367cc6e962af8d
Received on Mon Mar 17 2014 - 12:21:10 CET

This archive was generated by hypermail 2.3.0 : Mon Mar 17 2014 - 12:24:06 CET