[dev] Re: [dwm] Most fonts do not work

From: Joshua Krämer <joshua.kraemer_AT_gmail.com>
Date: Wed, 21 Jan 2015 19:22:20 +0100

On 2015-01-20, 21:32, Dmitrij D. Czarkoff wrote:

> Joshua Krämer said:
> > I have figured it out myself: the non-working fonts are available
> > with utf8 encoding only, but dwm (without Xft patch) does not
> > support utf8.
> Sorry, but this doesn't make any sense.
> Firstly, dwm "supports" utf-8 without any patches. (Although I don't
> normally use non-ASCII with dwm, I specifically tried now setting
> WM_NAME to "привет", and it worked just fine.)
> Next, utf-8 is not font encoding, so it can't influence font
> rendering. Utf-8 is responsible for set of glyphs that is displayed,
> but not for fonts.

Sorry for using the wrong term. What I meant is not utf-8 encoding
but iso10646-1. If I compile dwm with an iso10646-1-encoded font for
which an iso8859-1-encoded file also exists, the latter is used by dwm
instead. If an iso8859-1-encoded file does not exist, the font does
not work at all and the following error (besides others) is printed to

    drw: missing fontset: ISO8859-1

If you know how to use iso10646-1-encoded fonts with dwm/drw, please
let me know.

> Most likely, your problem is with missing font metadata. See
> mkfontscale(1) and mkfontdir(1) for details. Alternatively, you may
> have your font path wrong; see xset(1). But utf-8 has definitely
> nothing to do with your issue.

I have correct fonts.dir files in the relevant directories. The
relevant directories are in my font path, as confirmed with "xset q".
All the fonts work in other applications like xfontsel, xterm or
textadept. dwm is the only application where only the iso8850-1-encoded
fonts work, but not the iso10646-1-encoded fonts.

Thanks for all hints!
Received on Wed Jan 21 2015 - 19:22:20 CET

This archive was generated by hypermail 2.3.0 : Wed Jan 21 2015 - 19:24:11 CET