Re: [dev] [st] vim breaks Delete key in an ssh session

From: Hiltjo Posthuma <>
Date: Thu, 27 Feb 2020 09:34:45 +0100

On Wed, Feb 26, 2020 at 04:55:56PM +0100, Patrik Osgnach wrote:
> Hello all,
> I have this strange situation with st (compiled from git commit
> 895e5b5, without any patch):
> When I ssh from my local Linux PC (running Gentoo) to a SLES11SP4
> Server, the delete key is ineffective (nothing gets deleted).
> I can fix this with "tput smkx" but, if I run vim, the delete key is
> not working any more after I quit vim.
> To avoid interference with my settings, I ran multiple versions (from
> 7.2 to 8.1) of vim with "vim -u NONE" and saw the same effect.
> If I hit ^V Delete after logging in on the remote server I get
> ^[[P
> alter running tput smkx I get
> ^[[3~
> and after quitting vim I get again
> ^[[P
> The output of stty -a is identical in all of these 3 scenarios.
> Other terminals like xterm do not show this behaviour.
> Also, I don't get this behaviour when I run vim from an st on my local Linux PC.
> Any ideas?
> Best regards,
> Patrik

Have you tried updating the terminfo file for st (using the git version!) on
the remote server?

Is SLES11SP4 some enterprise distribution?

Kind regards,
Received on Thu Feb 27 2020 - 09:34:45 CET

This archive was generated by hypermail 2.3.0 : Thu Feb 27 2020 - 09:36:10 CET