Re: [hackers] [quark] Use sizeof() instead of magic constants || FRIGN

From: FRIGN <>
Date: Mon, 5 Sep 2016 09:25:21 +0200

On Mon, 5 Sep 2016 07:42:36 +0200
Anselm R Garbe <> wrote:

Hey Anselm,

> Quick note: your syntax usage of sizeof is not 100% accurate.
> Use 'sizeof(type)' with brackets but 'sizeof var' without.

I use sizeof always function-like and see no reason why I shouldn't use
"sizeof(var)" and instead use "sizeof var". It doesn't alter the code
behaviour and ultimately it's all about readability.
If you eyes have become accustomed to always use function-like syntax
for such operators the best bet is not to break this style because it's
not "necessary" to have parentheses for variable sizeof's.



Received on Mon Sep 05 2016 - 09:25:21 CEST

This archive was generated by hypermail 2.3.0 : Mon Sep 05 2016 - 09:36:17 CEST