Re: [hackers] [quark] Use sizeof() instead of magic constants || FRIGN

From: Anselm R Garbe <garbeam_AT_gmail.com>
Date: Mon, 5 Sep 2016 09:39:24 +0200

On 5 September 2016 at 09:34, Ali H. Fardan <raiz_AT_firemail.cc> wrote:
> I got an example:
> try compiling this code:
>
> #include <stdio.h>
>
> int
> main(void)
> {
> printf("%d", sizeof unsigned char);
> return (0);
> }

Why should I try. This is blatantly obvious wrong code.

I'm referring to NOT using parentheses to make it explicitely clear,
that the expression is not referring to a type. See sec. 6.5.3 in the
C lang spec for further details.

Cheers,
Anselm
Received on Mon Sep 05 2016 - 09:39:24 CEST

This archive was generated by hypermail 2.3.0 : Mon Sep 05 2016 - 09:48:19 CEST