[dev] [9base] rc can't find .

From: Jan Winkelmann <keks_AT_unstable.nl>
Date: Thu, 10 Jun 2010 22:52:24 +0000


I was running a werc+lighty+9base setup happily for a couple of days.
Suddenly it started throwing 500-errors and lighty log said that rc died
with signal 6. I tried running the werc.rc manually, but he throws a
rather strange error:

$ pwd
$ rc -x werc.rc
. /opt/plan9/etc/rcmain werc.rc
flag p
flag i
flag l
. werc.rc
werc.rc: rc: .: can't open: No such file or directory

To me it looks like he can't find the . command as soon as he is inside
the werc.rc, however he still knows it in interactive shell:

; .
rc: Usage: . [-i] file [arg ...]

I already tried removing the custom werc.rc and replacing it by the
original, but that didn't help either.

I don't really know what to look for at this point, especially because I
don't really know a lot about plan9. So, any help would be appreciated.

Thanks in advance,
Received on Thu Jun 10 2010 - 22:52:24 UTC

This archive was generated by hypermail 2.2.0 : Thu Jun 10 2010 - 23:00:03 UTC