Re: [dev] [9base] rc can't find .

From: Kris Maglione <>
Date: Thu, 10 Jun 2010 19:18:38 -0400

On Thu, Jun 10, 2010 at 10:52:24PM +0000, Jan Winkelmann wrote:
>I was running a werc+lighty+9base setup happily for a couple of days.
>Suddenly it started throwing 500-errors and lighty log said that rc died
>with signal 6. I tried running the werc.rc manually, but he throws a
>rather strange error:
>$ pwd
>$ rc -x werc.rc
>. /opt/plan9/etc/rcmain werc.rc
>flag p
>flag i
>flag l
>. werc.rc
>werc.rc: rc: .: can't open: No such file or directory
>To me it looks like he can't find the . command as soon as he is inside
>the werc.rc, however he still knows it in interactive shell:
>; .
>rc: Usage: . [-i] file [arg ...]
>I already tried removing the custom werc.rc and replacing it by the
>original, but that didn't help either.
>I don't really know what to look for at this point, especially because I
>don't really know a lot about plan9. So, any help would be appreciated.

Unless . is in your path, you need to write ./werc.rc

Kris Maglione
Every one is a moon, and has a dark side which he never shows to
	--Mark Twain
Received on Thu Jun 10 2010 - 23:18:38 UTC

This archive was generated by hypermail 2.2.0 : Thu Jun 10 2010 - 23:24:02 UTC