Re: [dev] Re: dwm puzzle [fixed; with blame]

From: Peter John Hartman <>
Date: Sun, 12 Sep 2010 10:56:51 -0400

On Sat, Sep 11, 2010 at 05:39:45PM -0400, TJ Robotham wrote:
> On Sat, Sep 11, 2010 at 04:44:12PM -0400, Peter John Hartman wrote:
> >
> > I should have said in my original report that the MODKEY+shift+space
> > solution is the way I dealt with these problems; I had suspected that
> > the isfloating rule is being ignored in such cases, but when we ran
> > 5.8.2 it worked just fine; perhaps you have the same bug I do. Try
> > the latest hg tip.
> >
> > Peter
> >
> Before my previous post I tested with hg tip and didn't hit your bug. Then I
> realized that hg tip includes the change that fixed it for you, so now I've
> retested with one before hg tip and I'm still not getting your bug. I was able
> to open a terminal, then open openoffice (which goes floating fullscreen,
> hiding the terminal), focus the terminal using MODKEY+j (still hidden behind
> openoffice), and successfully run a command in the terminal. From my
> understanding of your report, you were not able to do this.
> It looks like we just have the auto-floating in common, which at least has a
> reasonable explanation for why dwm is doing it (whether or not it should is a
> different can of worms). The focus problem could very well be specific to
> certain compiler versions.
> gcc version 4.3.2 (Debian 4.3.2-1.1)

Hmm. I think this is what is happening to me. For instance, it is fixed if
I do MODKEY+space to make it not a floater. So, on the can of worms, it
shouldn't auto-float; and it used to not auto-float. Unless I'm misunderstaanding

Received on Sun Sep 12 2010 - 16:56:51 CEST

This archive was generated by hypermail 2.2.0 : Sun Sep 12 2010 - 17:00:06 CEST