Re: [dev] stest review

From: Kurt H Maier <>
Date: Sat, 11 Feb 2012 10:02:11 -0500

On Sat, Feb 11, 2012 at 03:39:35PM +0100, Anselm R Garbe wrote:
> It's quite consistent in most suckless tools actually. One difference
> I stumbled upon is exactly stest, because it uses the clunky getopt()
> approach and I really wonder why it needs so many flags.

sbase uses getopt and I suspect will continue to do so. it's all very
well to go on about 'too much choice' but it's hard enough to get people
to implement fundamental unix utilities without also demanding they jump
through option parsing hoops for no technical reason.

if you like for() stuff so much, why not put it into a function and
stuff that into a library? maybe call it getopt?
Received on Sat Feb 11 2012 - 16:02:11 CET

This archive was generated by hypermail 2.3.0 : Sat Feb 11 2012 - 16:12:03 CET