Re: [dev] Applying patches to dwm

From: Pickfire <>
Date: Sat, 21 Nov 2015 21:48:33 +0800

On Sat, Nov 21, 2015 at 01:48:21PM +0100, Antonio Cardace wrote:
>I don't seem to be able to apply any patch which is present on
>, specifically here's what I tried:
>- I cloned the git repo of dwm
>- downloaded the statuscolours patch
>- did "git apply dwm-6.1-statuscolors.diff"
>and the output is:
>error: patch failed: drw.c:202
>error: drw.c: patch does not apply
>error: patch failed: drw.h:67
>error: drw.h: patch does not apply
>error: patch failed: dwm.c:261
>error: dwm.c: patch does not apply
>This happens with many patches I've tried to apply to my dwm.

I guess you are a newbie. Patches doesn't apply normally because that:

1. It is outdated, nobody has update it. You are welcome to update it.
2. You had applied another patch beforehand that overlap the patches.

To overcome these problem, try:

1. `git apply patch -3v`
2. Edit the file and find `======`, fix those lines, eg.
   - Remove <<<<< and >>>>>, just fix it.
3. `git add those files`
4. That patch is updated and you are welcome to add it to the wiki.

Good luck and have a nice day!

< Do what you like, like what you do. >
        \   ^__^
         \  (oo)\_______
            (__)\       )\/\
                ||----w |
                ||     ||
Received on Sat Nov 21 2015 - 14:48:33 CET

This archive was generated by hypermail 2.3.0 : Sat Nov 21 2015 - 15:00:16 CET