[dev] [st] vim breaks Delete key in an ssh session

From: Patrik Osgnach <patrik.osgnach_AT_gmail.com>
Date: Wed, 26 Feb 2020 16:55:56 +0100

Hello all,

I have this strange situation with st (compiled from git commit
895e5b5, without any patch):
When I ssh from my local Linux PC (running Gentoo) to a SLES11SP4
Server, the delete key is ineffective (nothing gets deleted).
I can fix this with "tput smkx" but, if I run vim, the delete key is
not working any more after I quit vim.
To avoid interference with my settings, I ran multiple versions (from
7.2 to 8.1) of vim with "vim -u NONE" and saw the same effect.

If I hit ^V Delete after logging in on the remote server I get

alter running tput smkx I get

and after quitting vim I get again

The output of stty -a is identical in all of these 3 scenarios.
Other terminals like xterm do not show this behaviour.
Also, I don't get this behaviour when I run vim from an st on my local Linux PC.
Any ideas?

Best regards,
Received on Wed Feb 26 2020 - 16:55:56 CET

This archive was generated by hypermail 2.3.0 : Wed Feb 26 2020 - 18:48:08 CET