[dev] [st] libxft-bgra X Error

From: Luuk van Baal <luukvbaal_AT_gmail.com>
Date: Mon, 19 Apr 2021 11:59:53 +0200

I was looking for pointers in regards to this error I'm receiving when
using libxft-bgra(https://gitlab.freedesktop.org/xorg/lib/libxft/-/merge_requests/1). I explained the issue in (https://gitlab.freedesktop.org/xorg/lib/libxft/-/merge_requests/1#note_884325):

"This patch (installed through this AUR package) leads to

X Error of failed request: RenderBadPicture (invalid Picture parameter)
  Major opcode of failed request: 139 (RENDER)
  Minor opcode of failed request: 8 (RenderComposite)
  Picture id in failed request: 0x3b84
  Serial number of failed request: 15315
  Current serial number in output stream: 15327

when scrolling through this file(https://raw.githubusercontent.com/luukvbaal/iconlookup/master/iconlookup) in suckless' simple terminal using a patched nerd font. Very peculiar I know but this is the only way I've been able to reproduce this error.
This sequence crashes the terminal every time:
open st -> open iconlookup in vim -> press 160gg to go to line 160(full size terminal showing 47 lines centered around line 160).
The same error does not happen when using different terminals but also does not happen in st when using the standard libxft from the arch repositories.
I'm interested in figuring this out but I'm not sure how to debug the
error. Would appreciate any pointers or thoughts regarding this."

I'm curious to know your thoughts on this as like I said the problem
does not occur with mainline libxft and st, does occur with libxft-bgra
and st, but does not occur with libxft-bgra and other terminals(tried
xterm/kitty/alacritty). Might this issue be fixed on st's side?

Best regards,
Luuk van Baal
Received on Mon Apr 19 2021 - 11:59:53 CEST

This archive was generated by hypermail 2.3.0 : Mon Apr 19 2021 - 13:48:08 CEST