Re: [dev] Is there a text editor following the UNIX philosophy?

From: Ismael Luceno <>
Date: Tue, 15 Feb 2022 15:01:23 +0100

El dom, 13 feb 2022 a la(s) 22:23, Kyryl Melekhin
( escribió:
> Michael Hendricks <> wrote:
> > Agreed.
> >
> > > If anybody wants to go and fix the build let me know of your fork or
> > > patch as I want to try it, out of curiosity.
> >
> > After cloning the repo[1], I ran `autoreconf -fi` to generate a
> > configure script. Then `./configure && make`. Aside from the
> > autotools bloat, the build proceeded without trouble for me on
> > OpenBSD.
> >
> > 1:
> Indeed, `autoreconf -fi` worked, thanks. There is an error if one tries to
> run just autoconf or autoreconf without arguments. Looks like this:
> I have no idea what these errors mean, so when I got them I just gave up
> initially, as it would of been stupid to waste time trying to figure it
> out... Imagine having a bloated build tool, that does not just work,
> pathetic. I also find especially frustrating how the INSTALL file tells
> the user to run autoconf with no arguments.

These errors mean the named auxiliary build scripts (needed for
portability) are not present and must be provided...

Technically, it's wrong to ask users to run autoreconf, projects must
provide release tarballs with the pregenerated build system at
releases, this is not just a convenience, first because that step is
not repeatable and there's no way to fix it except by using the exact
same autoconf environment, and because other actions might be part of
the release process which make a snapshot different from a release
tarball (e.g. bundling submodules, automated editing of some files to
match the release, etc.).
Received on Tue Feb 15 2022 - 15:01:23 CET

This archive was generated by hypermail 2.3.0 : Tue Feb 15 2022 - 15:36:09 CET