[dwm] stupid problem with key bindings

From: Giorgio Lando <patroclo7_AT_gmail.com>
Date: Sat, 29 Dec 2007 17:24:15 +0100

Hi, I am unable to bind a command in dwm including shell `` through config.h.
I am probably making some stupid shell syntax error or forgetting
something obvious.

The command should open in firefox the contents of the X selection
buffer. So xsel gives me the buffer. In the interactive shell, the
following command works when the buffer consists in an URL:

firefox `xsel`

Now I have tried the following line in config.h:

 { MODKEY, XK_o, spawn, "exec firefox `xsel`" },

but nothing happened. Then, inspired by the default way of invoking
dmenu, I have tried also:

 { MODKEY, XK_o, spawn, "exe=`xsel` && exec firefox $exe" },

Finally I have tried the silly:

 { MODKEY, XK_o, spawn, "exec firefox '`xsel`'" },

But, as obvious, then the key combination opens firefox with the literal URL 'xsel'
(I tried this to verify that the problem is not in the syntax of config.h)

My default shell is bash. Any suggestion welcome
Received on Sat Dec 29 2007 - 17:24:40 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 15:14:27 UTC