Re: [dwm] [PATCH] small fix in propertynotify

From: Szabolcs Nagy <nszabolcs_AT_gmail.com>
Date: Thu, 12 Feb 2009 19:07:15 +0100

On 2/12/09, Peter Hartlich <sgkkr_AT_hartlich.com> wrote:
>> - if((ev->window == root) && (ev->atom = XA_WM_NAME))
>> + if((ev->window == root) && (ev->atom == XA_WM_NAME))
>
> Why not remove the inner parens as well? Without them, gcc would have
> noticed.

yes, that's how i'd do (but in certain cases parents makes the code
easier to read)

now this is what i found in toggletag():

         if(!sel)
                 return;
         
         mask = sel->tags ^ (arg->ui & TAGMASK);
- if(sel && mask) {
+ if(mask) {
Received on Thu Feb 12 2009 - 18:07:15 UTC

This archive was generated by hypermail 2.2.0 : Thu Feb 12 2009 - 18:12:04 UTC