[hackers] [slock] Use explicit strcmp() instead of inlining it || FRIGN

From: <git_AT_suckless.org>
Date: Mon, 10 Oct 2016 20:40:03 +0200 (CEST)

commit c96e725df0c449abb5f1f6a3b604f64fa69c4756
Author: FRIGN <dev_AT_frign.de>
AuthorDate: Sun Oct 2 00:10:45 2016 +0200
Commit: Markus Teich <markus.teich_AT_stusta.mhn.de>
CommitDate: Mon Oct 10 20:40:13 2016 +0200

    Use explicit strcmp() instead of inlining it
    
    Makes it a tad more readable; the previous "optimization" will be done
    by the compiler anyway.

diff --git a/slock.c b/slock.c
index 6dbf966..4d7f06f 100644
--- a/slock.c
+++ b/slock.c
_AT_@ -100,7 +100,7 @@ gethash(void)
         hash = pw->pw_passwd;
 
 #if HAVE_SHADOW_H
- if (hash[0] == 'x' && hash[1] == '\0') {
+ if (!strcmp(hash, "x")) {
                 struct spwd *sp;
                 if (!(sp = getspnam(pw->pw_name)))
                         die("slock: getspnam: cannot retrieve shadow entry. "
_AT_@ -108,7 +108,7 @@ gethash(void)
                 hash = sp->sp_pwdp;
         }
 #else
- if (hash[0] == '*' && hash[1] == '\0') {
+ if (!strcmp(hash, "*")) {
 #ifdef __OpenBSD__
                 if (!(pw = getpwuid_shadow(getuid())))
                         die("slock: getpwnam_shadow: cannot retrieve shadow entry. "
Received on Mon Oct 10 2016 - 20:40:03 CEST

This archive was generated by hypermail 2.3.0 : Mon Oct 10 2016 - 20:48:26 CEST