hackers mail list archive by subject
- [dmenu][patch] Improve speed of drw_text when provided with large strings
- [hackers] [dwm][PATCH] drawbar: Don't expend effort drawing bar if it is occluded
- [hackers] [dwm][patch] gaplessgrid focus left/right
- [hackers] [ii] Reduce effective buffer size per channel input. || Christoph Lohmann
- [hackers] [ii][PATCH 1/2] Increase ping timeout for bad connections.
- [hackers] [libgrapheme] Add "clean-data" to PHONY-targets || Laslo Hunhold
- [hackers] [libgrapheme] Add a remark on standard conformance in README || Laslo Hunhold
- [hackers] [libgrapheme] Add generator for compressed O(1)-lookup-table || Laslo Hunhold
- [hackers] [libgrapheme] Add lg_utf8_*() manuals to Makefile MAN3-variable || Laslo Hunhold
- [hackers] [libgrapheme] Add manual pages for lg_utf8_*() and refactor lg_grapheme_nextbreak() || Laslo Hunhold
- [hackers] [libgrapheme] Add README and change title and introduction in Makefile and manuals || Laslo Hunhold
- [hackers] [libgrapheme] Alphabetic ordering of variables in config.mk || Laslo Hunhold
- [hackers] [libgrapheme] Break some long lines || Laslo Hunhold
- [hackers] [libgrapheme] Bump to version 1 || Laslo Hunhold
- [hackers] [libgrapheme] Call ldconfig after install and uninstall || Laslo Hunhold
- [hackers] [libgrapheme] Cast pedantically || Laslo Hunhold
- [hackers] [libgrapheme] Change lg_grapheme_isbreak() return type from int to bool || Laslo Hunhold
- [hackers] [libgrapheme] Change parameter order in lg_utf8_decode() || Laslo Hunhold
- [hackers] [libgrapheme] Coding style and explicit double-cast || Laslo Hunhold
- [hackers] [libgrapheme] Consistently refer to "codepoints" as "codepoints", not "code points" || Laslo Hunhold
- [hackers] [libgrapheme] Encourage strict aliasing for library users (uint8_t * -> char *) || Laslo Hunhold
- [hackers] [libgrapheme] Ensure const-correctness in cast in lg_utf8_decode() || Laslo Hunhold
- [hackers] [libgrapheme] Fix a few manpage-errors found by the linter || Laslo Hunhold
- [hackers] [libgrapheme] Fix memory leaks during header-generation || Laslo Hunhold
- [hackers] [libgrapheme] Improve a small edge-case in lg_utf8_decode() || Laslo Hunhold
- [hackers] [libgrapheme] Improve parsing of hexadecimal strings || Laslo Hunhold
- [hackers] [libgrapheme] Make lg_utf8_*() NULL-agnostic || Laslo Hunhold
- [hackers] [libgrapheme] Make lists in Makefile more idiomatic and avoid breaks || Laslo Hunhold
- [hackers] [libgrapheme] Match function parameters in code and documentation || Laslo Hunhold
- [hackers] [libgrapheme] Optimize bsearch-comparison-function for cp-ranges || Laslo Hunhold
- [hackers] [libgrapheme] Properly set internal functions as static || Laslo Hunhold
- [hackers] [libgrapheme] Reduce number of iterations for grapheme-performance-test || Laslo Hunhold
- [hackers] [libgrapheme] Refactor API ("lg_" prefix, better naming scheme) || Laslo Hunhold
- [hackers] [libgrapheme] Refactor data-generation and library structure || Laslo Hunhold
- [hackers] [libgrapheme] Refactor Makefile, add dist-target and add test-util || Laslo Hunhold
- [hackers] [libgrapheme] Refactor manual pages, document lg_grapheme_isbreak() || Laslo Hunhold
- [hackers] [libgrapheme] Refine types (uint8_t -> char, uint32_t -> uint_least32_t) || Laslo Hunhold
- [hackers] [libgrapheme] Reintroduce the "grapheme_" prefix || Laslo Hunhold
- [hackers] [libgrapheme] Rename API functions to improve readability || Laslo Hunhold
- [hackers] [libgrapheme] Rename functions/defines/files from "grapheme" to "character" || Laslo Hunhold
- [hackers] [libgrapheme] Rename GRAPHEME_INVALID_CODE_POINT to GRAPHEME_CODEPOINT_INVALID || Laslo Hunhold
- [hackers] [libgrapheme] Rename GRAPHEME_SEGMENTATION_STATE to GRAPHEME_STATE || Laslo Hunhold
- [hackers] [libgrapheme] Rename LG_CODEPOINT_INVALID to LG_INVALID_CODE_POINT || Laslo Hunhold
- [hackers] [libgrapheme] Reorder CFLAGS || Laslo Hunhold
- [hackers] [libgrapheme] Rewrite grapheme_next_character_break() and add size-parameter || Laslo Hunhold
- [hackers] [libgrapheme] Severely speed up grapheme cluster break detection || Laslo Hunhold
- [hackers] [libgrapheme] Update UTF-8-decoder test for modified NULL-case || Laslo Hunhold
- [hackers] [libgrapheme] Use SIZE_MAX instead of (size_t)-1 || Laslo Hunhold
- [hackers] [libgrapheme] version 1 release
- [hackers] [PATCH st v2] Fix null pointer access in strhandle
- [hackers] [PATCH st] Fix null pointer access in strhandle
- [hackers] [sbase][PATCH] flock: call exec without forking
- [hackers] [st][PATCH] Fix overtyping wide characters.
- [hackers][st][PATCH] Add support for OSC color sequences.
- Last message date: Fri Dec 31 2021 - 19:28:41 CET
- Archived on: Thu Nov 21 2024 - 10:24:50 CET