[wmii] getting stuck with an old 'status' - what's going on?

From: Jeffrey Lim <jfs.world_AT_gmail.com>
Date: Fri, 10 Mar 2006 09:56:31 +0800

hi guys, been playing aorund with status ever since my last question
to the list (about displaying battery status), and it's been great.
However, i seem to have hit into a problem, as described by my
subject. It seems as if every time i run wmii, i get stuck with an old
'status' script from God knows where.

Say i make a change to the date display in status, so that it displays
in the format


(hour and minutes in '[ ]' brackets), instead of


(which was the format in an earlier version of the 'status' script)

When i run wmii, i still get the OLD date display format in wmiibar -
'Fri_Mar_10_09:30:28'!!! I have even verified, and tried running
'status' manually, whereupon running manually, the date format is
~prompty changed to the correct format ('Fri_Mar_10_[09:30:]28')!!! I
really dont get it here.

My diagnostic steps:

1. try checking the 'date' line in status, by running it manually
date=`date | sed 's/ ....$//;s/ / /;s/ ...$//;s/
echo $date

Result - ok, the sed script works fine - date format is indeed

2. ls -la ~/.wmii-2.5 => nothing here. Except '.', and '..', of course

3. slocate status |grep status$ => only a few suspects.
/etc/wmii-2.5/status, /sys/class/net/eth1/wireless/status,
/usr/share/pixmaps/gaim/status. Now dont tell me that i am running
/sys/class/net/eth1/wireless/status, or /usr/share/pixmaps/gaim/status
instead?? Not likely, or even possible, of course.

4. lsof |grep status => (NOTE this is done BEFORE i try to 'fix' the
problem by running /etc/wmii-2.5/status *manually*)
jf 2663 0.0 0.1 3144 1436 ? S 07:52 0:01
/bin/sh /etc/wmii-2.5/status

ok, so /etc/wmii-2.5/status is being run!! So what the heck's going on
(ps. - i have changed my 'status' to a shell script instead)??

I am also sure in a certain sense that /etc/wmii-2.5/status IS being
actually run - because other changes that i have made to the status
script have been reflected in wmiibar!!

5. LAST, try manually forcing the run of /etc/wmii-2.5/status at the
command line with a '/etc/wmii-2.5/status &'
=> date display format in wmiibar gets FIXED immediately.

I cannot for the life of me figure out what is going on. Could somebody help me?

Received on Fri Mar 10 2006 - 02:56:32 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 16:00:56 UTC