[wmii] Re: wmiirc Locking Up

From: Jeremy Hankins <nowan_AT_nowan.org>
Date: Wed, 14 Jun 2006 09:55:25 -0400

Ryan Kirkpatrick <linux_AT_rkirkpat.net> writes:

> No, only NFS, and not on the systems having this problem. My laptop
> has displayed it once or twice, and it has never has any network
> mounts. Where I have seen it more often is on my server, which is
> hosting several X-terminals. I have a couple of disk-less PCs running
> only an X server and using XDM to connect back to the server. All
> applications, including wmii, are running on the server, as X
> clients. While the server does offer NFS shares to other systems, the
> home directories that wmiirc is running out of are local on the server
> itself. Maybe it has something to do with multiple instances of wmiirc
> running on the same system at the same time?

Could wmiir be hanging? I've had that happen to me a few times. In
fact, it got especially bad for a while when I had my wmiirc (python)
set up to spawn threads for status monitor stuff, and had a couple of
such (native python) threads going. Running a status script (with a
thread to monitor it) didn't cause the problem too often, but if the
subthread was simply running a python function one of the wmiir
processes would frequently hang. I tried adding a lock to the function
that runs wmiir and the problem hasn't recurred. But then, I haven't
been restarting my wmiirc as much either, because I've been working on
other things lately.

The hang generally occurred when the status thread tried to write to
/bar/<status-name>/colors (which it does almost first thing). The first
such thread would run fine, but with the second the wmiir process would

Jeremy Hankins <nowan_AT_nowan.org>
PGP fingerprint: 748F 4D16 538E 75D6 8333  9E10 D212 B5ED 37D0 0A03
Received on Wed Jun 14 2006 - 15:55:38 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 16:09:21 UTC