Re: [wmii] problems with (some) keybindings

From: Damien Wyart <>
Date: Tue, 15 May 2007 21:58:34 +0200

> > i fixed it by resolving $DOWN, $UP, $LEFT and $RIGHT by hand...
> > i don't understand the problem though...

* Kris Maglione <> [070515 02:30]:
> I understand the problem, and it was fixed before the snap was
> released after it had appeared.

Not for me: after upgrading from Debian Unstable current snapshot
(3.6~rc2+20070501-1) to latest official one (3.6pre~20070511), I still
have the same $DOWN... problem (and another one, see below).

> Again, use the latest snap. You can build a deb for it, just 'apt-get
> install build-essential libxext-dev x11proto-xext-dev libx11-dev
> debhelper', and run 'make deb'.

Thanks for these useful explanations.

I also noticed a more annoying problem with wmiirc from the latest snap.
The eval line used to be:

  eval "$(eventstuff | sed "s/\\\$MODKEY/$MODKEY/g;s/^[ ]//" | wmiiloop)"

in previous versions (with IFS='' and unset IFS surrounding it, but
removing them doesn't seem to make any difference).

In the latest version, it is :

eval "$(eventstuff | sed 's/^[ ]//' | wmiiloop)"

and this more or less crashes (or stucks) wmii : the mouse pointer
moves, but the keys do not respond and the status bar stays white. The
processes have to be killed by hand. Reverting to the previous one seems
to fix the problem, but the $DOWN... issue is still there.

I also tried the new eval from latest official snap with Debian's wmii
and it also crashes, so this doesn't seem directly related to wmii

I do not know if the $DOWN... problem is related to this one or not.

Hope my explanations were clear ; I can do other tests if needed.


Damien Wyart
Received on Tue May 15 2007 - 21:58:34 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 16:24:21 UTC