Re: [dwm] some opinions

From: Anselm R. Garbe <>
Date: Thu, 25 Oct 2007 10:09:00 +0200

Hi Robert,

   I consider the idea of having a Button struct for 4.7.


On Thu, Oct 25, 2007 at 03:20:46AM +0200, Robert Figura wrote:
> Hi folks,
> I have worked on my sandbox again and would like to share some
> opinions. A new modified version of dwm is again downloadable via
> In the attachment you can find part of the modifications as patch to
> dwm.c. This patch is to help the discussion here and won't work without
> a proper config.h, so i suggest to download the tarball from the url
> above anyways.
> I tried to move some of the modifications i made in dwm.c to the
> separate xtile.c file. And that's where my first opinion comes from:
> xtile.c's stickyview() function needs the only three global variables
> that aren't available at the inclusion of config.h. See patch for my
> quick hack.
> The next opinion is that there should be a configuration mechanism for
> buttonpress() similar to keypress(). A partial solution can be found
> in the patch and the problem follows close up: How to give a client *
> to a handler?
> Resize hinting appeals to me. But it leads to nasty problems. In tiling
> modes it felt right to allow shrinking and incremental hinting. I also
> think these features should be configurable via rules[]. The code for
> this is in applyrules() and currently works only with xtile.c's tilers.
> The other thing with resizehints is that the last client gets the
> benefit from the space saved. I'd like to layout the clients in reverse
> order but that'd mean more hacking than i'm currently willing to do.
> Of course: The *correct* way to do this would be calculating all
> dimenstions in a separate pass but then i'm quite sure that this method
> won't have many fans here. So we'll have to live with the occasional
> waste of space at the bottom.
> While testing with OJ Mixer i found something in configurerequest()
> which i would consider a bug. OJ Mixer has a button to toggle the size
> of it's window. I think arrange() really should be called there.
> Maybe i haven't understood dwm's togglemax() feature but i think
> something like anydot's monocle is better. I made a slightly different
> conception which allows one to change the visible window via the
> focusnext()/prev() keys.
> End of Opinions.
> Recently i found out that i can save some mouseclicks with sticky tags
> and roll() (formerly named unzoom(), pronounce dump()) and that it was
> worth the effort. (Wink wink)
> Regards
> - Robert Figura

 Anselm R. Garbe >< >< GPG key: 0D73F361
Received on Thu Oct 25 2007 - 10:09:00 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 15:02:07 UTC