Re: [dev] No rule to make target `/usr/local/lib/libixp.a'

From: Kris Maglione <>
Date: Fri, 13 Nov 2009 05:13:27 -0500

On Tue, Nov 10, 2009 at 11:04:22AM +0100, Davide Anchisi wrote:
>I already posted a similar problem, but as it is still there and don't
>know how to solve it, here it is.
>When I run 'make' to compile wmii (hg2590), I get the following error:
> make[2]: *** No rule to make target `/usr/local/lib/libixp.a',
>needed by `wmii.out'. Stop.
>I thought I'm missing something on my newly installed debian GNU/Linux
>64bit system, but I couldn't figure out what it is (and I have no
>problemin compiling other packages).
>More strangely, if I run ' make deb' first, which fails as reported in
>a previous mail, and then ' make clean', wmii compiles!
>Then it installs ('make install') under debian/wmmi-hg (as in
>, which is not removed by 'make clean'), and finally,
>if I move those files by hand in the right location wmii is working
>So it seems I have all the tools to compile.

You need to install libixp, either to the same PREFIX as wmii or
you need to change the LIBIXP variable to point to it.

Unfortunately, I can't test on debian except to send my sources
to the Launchpad build farm, and they always make clean first. I
really can't see why there should be a problem.

Kris Maglione
APL is a mistake, carried through to perfection.  It is the language
of the future for the programming techniques of the past: it creates a
new generation of coding bums.
	--Edsger W. Dijkstra
Received on Fri Nov 13 2009 - 10:13:27 UTC

This archive was generated by hypermail 2.2.0 : Fri Nov 13 2009 - 10:24:03 UTC